Guix will hold its first online conference November 22nd. Propose a talk before November 6th. Learn more!

perl-task-weaken 1.06 Ensure that a platform has weaken support

One recurring problem in modules that use Scalar::Util's weaken function is that it is not present in the pure-perl variant. If Scalar::Util is not available at all, it will issue a normal dependency on the module. However, if Scalar::Util is relatively new ( it is >= 1.19 ) and the module does not have weaken, the install will bail out altogether with a long error encouraging the user to seek support.